If you encounter the error message "You’ve hit the limit for this feature. Please email support for help." while using Notta, this article explains the cause and provides solutions.
Cause
Notta sets monthly usage limits for features like transcription time, file transcription, and AI summaries. The message "This feature limit has been reached" indicates that your usage for one or more of these features has hit its cap within the current reset cycle.
For details on the usage and calculation method of these features, please check the following help documentation: Usage calculation rules for Notta features
Solution
Generally, the available allowance for each feature increases incrementally with your plan tier. If you'd like to increase your available allowance to remove usage restrictions, consider upgrading to a higher-tier plan or adding more seats. For details on feature allowance distribution across different plans, please refer to our pricing page.
For specific steps on how to upgrade your plan, please consult the following help documentation: Change your subscription plan on Notta
If you're currently on a Business Plan, you can also consider increasing your allowance by adding more seats. Your allowance multiplies based on the total number of seats in your workspace, and these allowances are shared by everyone in the workspace.
For information on how to add seats, please refer to the following help documentation: How do I add seats to my Notta Business Plan?
FAQ
While Business members have no limit on the Transcription quota, there are usage limits on the number of file uploads (200 times/month per account) and the AI summaries quota (200 times/month per account) .
For details, please refer to the official website's pricing page.
If your usage is restricted, please confirm whether your these usage status has reached the limit. If the current usage limits are not sufficient for your needs, you can increase your usage limit by adding more seats for your workspace